Yes!! It’s true, Logic Pro 9 on PPC G5!!

Want to try? Make sure you’re running OS 10.5.7, then install LP9 and then it should be working…..

Glad I tried this first, I was almost fooled in buying a new Mac Pro. My G5 Quad is still a very capable machine, so I hope it will run at least another year.

Logic-Pro-9-on-G5